Unplanned degraded performance for Business KYC
Incident Report for Solaris
Resolved
This incident has been resolved.
Posted May 17, 2022 - 17:40 CEST
Identified
Without advance notice or documentation, German Handelsregister released a major platform update which disrupted our provider’s connection.
Our provider is working on restoring the full functionality and while the access to the data via API has been restored, the restoration of document orders from the German Handelsregister remains in progress.
At the same time downloading documents from the Dutch commercial registry also experienced technical issue and was deactivated by the provider until a fix for the root cause is implemented.
We are closely monitoring the situation and will update the status page once the full functionality has been restored.
Posted Apr 28, 2022 - 17:23 CEST
Update
We are working on this degraded performance issue actively with our provider.
Posted Apr 27, 2022 - 18:35 CEST
Update
We are still working in with the provider in order to mitigate the impact.
Posted Apr 27, 2022 - 15:56 CEST
Investigating
Summary: The root cause that is causing an unplanned degraded performance for Business KYC has been identified to be related to a third party provider outage due to unannounced platform changes in the German and Dutch commercial registries. We are working in collaboration with the provider in order to mitigate the impact.

Partner Impact: Automated document retrieval is not possible for DE & NL legal forms.
This means all our BKYC partners experience delays on onboardings as BKYC Operations team have to manually fetch those documents.
Posted Apr 27, 2022 - 11:01 CEST
This incident affected: Identification.