Unplanned Partial Outage for Digital Banking API Services
Incident Report for Solaris
Resolved
A fix was applied for the unplanned Partial Outage affecting Digital Banking API services. Services have been monitored and all operations are running within normal service levels.

Partner Impact Resolution:

• Intermittent 5xx error messages are no longer being returned across multiple DiBa endpoints, such as creating new SEPA Credit Transfers or getting account information.

Customer Impact Resolution:

• Customers trying to initiate a new Digital Banking operations are no longer presented with a generic error message in the mobile or web applications.

Impacted endpoints:

• GET /v1/accounts/{id}
• POST /v1/persons/{person_id}/accounts/{account_id}/transactions/sepa_direct_debit
• POST /v1/persons/{person_id}/accounts/{account_id}/transactions/sepa_credit_transfer

API Reference Documentation: To understand more about the impacted endpoint/s please read the following public documentation:

https://docs.solarisgroup.com/api-reference/digital-banking/account-management/#tag/Accounts/paths/~1v1~1accounts~1{id}/get
https://docs.solarisgroup.com/api-reference/digital-banking/sepa-transfers/#tag/SEPA-Credit-Transfers

This incident is resolved. No further updates will be provided.

In case of any questions or concerns, please contact us by sending an email at incidents@solarisbank.de or through our dedicated ticketing platform.
Posted Mar 27, 2024 - 06:26 CET
Investigating
An unplanned Partial Outage for Digital Banking API services has been identified. We are working to restore the impacted services as soon as possible.

Partner Impact:

• Intermittent 5xx error messages are being returned across multiple DiBa endpoints, such as creating new SEPA Credit Transfers or getting account information.

Customer Impact:

• Customers trying to initiate a new Digital Banking operations may be presented with a generic error message in the mobile or web applications.

Impacted endpoints:

• GET /v1/accounts/{id}
• POST /v1/persons/{person_id}/accounts/{account_id}/transactions/sepa_direct_debit
• POST /v1/persons/{person_id}/accounts/{account_id}/transactions/sepa_credit_transfer

API Reference Documentation: To understand more about the impacted endpoint/s please read the following public documentation:

https://docs.solarisgroup.com/api-reference/digital-banking/account-management/#tag/Accounts/paths/~1v1~1accounts~1{id}/get
https://docs.solarisgroup.com/api-reference/digital-banking/sepa-transfers/#tag/SEPA-Credit-Transfers

We apologize for any inconveniences this outage may have caused. In case of any questions or concerns, please contact us by sending an email at incidents@solarisbank.de or through our dedicated ticketing platform.
Posted Mar 27, 2024 - 02:54 CET
This incident affected: Digital Banking.